广告图片2广告图片

股票配资平台公司 经典K线形态之双阳接力形态及其案例解析

通达信金宝盆主图指标公式

AF1:=REF(O,1);
股票配资平台公司  经典K线形态之双阳接力形态及其案例解析


AF2:=ABS((REF(C,1)-AF1)/AF1);

AF3:=ABS((REF(H,1)-AF1)/AF1);

AF4:=ABS((REF(L,1)-AF1)/AF1);

BF1:=ABS((AF2+AF3+AF4)/3);

BF2:=O*BF1;

预测低一:=O-BF2;

预测高一:=O+BF2;

今日保护价:=(REF(C,2)+REF(C,1)+O)/3 ,COLOR4080FF,NODRAW;

开盘价1:=OPEN;

开盘价2:=REF(OPEN,1);

最高价1:=HIGH;

最高价2:=REF(HIGH,1);

最低价1:=LOW;

最低价2:=REF(LOW,1);

收盘价1:=CLOSE;

收盘价2:=REF(CLOSE,1);

AAF:=最高价2;

BBF:=最低价2;

CCF:=开盘价2;

DDF:=收盘价2;

EEF:=(AAF+BBF+CCF+2*DDF)/5;

AAAF:=EEF+(AAF-BBF);

BBBF:=2*EEF-BBF;

CCCF:=2*EEF-AAF;

DDDF:=EEF-(AAF-BBF);

上升突破价:=AAAF;

上升阻力价:=BBBF;

下跌支撑价:=CCCF;

下跌反转价:=DDDF;

E:=(HIGH+LOW+OPEN+2*CLOSE)/5;

阻力:=E+(HIGH-LOW);

支撑:=E-(HIGH-LOW);

EEE:=(EEF+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;

心理价:=EEE;

FFF:=(EEE+开盘价1)/2;

GGG:=(预测低一+FFF)/2;

预测低二:=MIN(GGG,支撑);

DRAWRECTREL(0,0,360,399,IF(120,RGB(10,0,0),0));

DRAWRECTREL(0,0,360,8,IF(120,RGB(280,0,0),0));

DRAWRECTREL(0,265,360,273,IF(120,RGB(280,0,0),0));

预测高二:=MAX(MA(REF(HIGH,1)/REF(CLOSE,2),27)*REF(CLOSE,1),阻力);

DRAWTEXT_FIX(1,0.18,0.15,0,'测低:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.24,0.17,0,CONST(预测低二)),COLORCYAN;

DRAWTEXT_FIX(1,0.04,0.15,0,'测高:'),COLORFFFFFF;

DRAWNUMBER_FIX(1,0.10,0.17,0,CONST(预测高二)),COLORYELLOW;

MQ1:=12;

MQ2:=50;

MQ3:=60;

EXP1:=EXPMA(CLOSE,MQ1);

EXP2:=EXPMA(CLOSE,MQ2);

EXP3:=EXPMA(CLOSE,MQ3);

AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);

BA:=EMA(AB,5);

A1:=REFDATE(REF(HHV(H,96),5),DATE);

B1:=REFDATE(REF(LLV(L,96),5),DATE);

DY:=((A1)+(B1))/2;

箱顶:=IF(AB>0 AND AB-BA<=0,A1,A1),LINETHICK3,COLOR00FF00;

箱腰:=IF(AB>0 AND AB-BA<=0,DY,DY),LINETHICK3,COLOR00FF00;

箱低:=IF(AB>0 AND AB-BA<=0,B1,B1),LINETHICK3,COLOR00FF00;

高1:=IF(AB>0 AND AB-BA>0,A1,DRAWNULL),LINETHICK3,COLORRED;

中1:=IF(AB>0 AND AB-BA>0,DY,DRAWNULL),LINETHICK3,COLORRED;

低1:=IF(AB>0 AND AB-BA>0,B1,DRAWNULL),LINETHICK3,COLORRED;

顶周期:=TOPRANGE(H);底周期:=LOWRANGE(L);

上内:=LLVBARS(H,顶周期);上外:=LLVBARS(L,顶周期);

下内:=HHVBARS(L,底周期);下外:=HHVBARS(H,底周期);

上力度:=HHV(L,上内+1)>LLV(H,上内+1);

下力度:=HHV(L,下内+1)>LLV(H,下内+1);

上包含:=COUNT(L>=REF(L,1),上外)>2 AND COUNT(H>=REF(H,1),上内)>2;

下包含:=COUNT(H<=REF(H,1),下外)>2 AND COUNT(L<=REF(L,1),下内)>2;

顶0:=顶周期 AND 上力度 AND 上包含 AND 上外>3;

底0:=底周期 AND 下力度 AND 下包含 AND 下外>3;

顶分天数:=BARSLAST(顶0);

底分天数:=BARSLAST(底0);

含中间K线:=IF(顶分天数=0,底分天数,顶分天数)>=3;

顶:=顶0 AND 含中间K线 AND H=HHV(H,BARSLAST(底0));

底:=底0 AND 含中间K线 AND L=LLV(L,BARSLAST(顶0));

NOTEXT上笔划线:DRAWLINE(底,L,顶,H,0),COLORMAGENTA,LINETHICK3;

NOTEXT下笔划线:DRAWLINE(顶,H,底,L,0),COLORLIGREEN,LINETHICK3;

分界点:=NOTEXT上笔划线 AND NOTEXT下笔划线 ;

位置调整:=

IF(PERIOD=11,0.02, IF(PERIOD=10,0.02, IF(PERIOD=9,0.02, IF(PERIOD=8,0.001, IF(PERIOD=7,0.02, IF(PERIOD=6,0.01, IF(PERIOD=5,0.005, IF(PERIOD=4,0.002, IF(PERIOD=3,0.001, IF(PERIOD=2,0.001, IF(PERIOD=1,0.0003, IF(PERIOD=0,0.0002,0))))))))))));

DRAWNUMBER(分界点 AND 顶,H+H*位置调整+0.2,H),COLORLIRED;

DRAWNUMBER(分界点 AND 底,L-0.12,L),COLORYELLOW;

STICKLINE(分界点 AND 底,B1,B1+0.2,6,0),COLORMAGENTA;

STICKLINE(分界点 AND 顶,A1,A1-0.2,6,0),COLORGREEN;

买线:=EMA(C,3);

卖线:=EMA(SLOPE(C,21)*20+C,55)*1;

买卖差:=(买线-卖线),COLORYELLOW,NODRAW;

MID:=MA(CLOSE,13);

B3:=MA(C,1);

B4:=SMA(SMA(SMA(B3,2,1),2,1),2,1),COLORYELLOW;

SMA5:=MA(B4,3),COLORYELLOW;

STICKLINE(买卖差>=0 OR B4> SMA5,(买线-买卖差*0.80),MID,2,0),COLORRED;

STICKLINE(买卖差<0 OR B4<=SMA5,(卖线+买卖差*0.50),MID,2,0),COLORBLUE;

主力线:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*

SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK1,POINTDOT;

超短线:=(((主力线-LLV(主力线,21))/(HHV(主力线,21)-LLV(主力线,21)))*(4))*(0.5),COLORYELLOW,LINETHICK3,NODRAW;

金钻趋势:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK2,COLORLIRED;

斜率:=SLOPE(金钻趋势,3)*10,COLORYELLOW,NODRAW;

速率:=10*(斜率-REF(斜率,1)),COLORMAGENTA,NODRAW;

AA1:=CROSS(买卖差,0) AND COUNT(CROSS(买卖差,0) ,10)=1;

AA2:=CROSS(0,买卖差) AND COUNT(CROSS(0,买卖差),10)=1;

FF:=EMA(CLOSE,3);

MA15:=EMA(CLOSE,21);

TYP:=(CLOSE+HIGH+LOW)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

涨A:=IF(REF(CCI,1)<100,CCI>120,CCI>100);

涨:=CROSS(FF,MA15) OR FF>=MA15 OR 涨A,COLORRED;

降:=(CROSS(MA15,FF) OR FF<MA15) AND NOT(涨),COLORGREEN;

DRAWTEXT(降 AND COUNT(降,3)=1 ,(B4 + 0.04),'降'),COLOR00FF00;

DRAWTEXT(涨 AND COUNT(涨,5)=1 ,(B4-0.05),'涨'),COLORMAGENTA;

N:=IF(BARSCOUNT(C)>=8,8,BARSCOUNT(C));

AMOV:=VOL*(C+L+H)/3;

MN:=SUM(AMOV,N)/SUM(VOL,N),LINETHICK3,COLORYELLOW;

ZA5:=C-MN,NODRAW,COLORCYAN;

VLD:=CROSS(MA(C,13),MA(C,21));

RSS:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

K1:=SMA(RSS,10,1);

D1:=SMA(K1,5,1);

KK:=INTPART(K1);

DD:=INTPART(D1);

TFXXS:=KK+DD;

TGLD:=MOD(TFXXS,10);

TGLXS:=(TFXXS-REF(TFXXS,1))*10;

乖离:=TGLXS,LINETHICK1,COLORWHITE,NODRAW;

跌:=(斜率<-0.1 OR 降 OR 速率<0 OR 乖离<0) AND ZA5<0 AND NOTEXT下笔划线 ,COLORCYAN;

Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;

Q3:=SMA(Q2, 9, 1);

Q4:=SMA(Q3, 3, 1);

长趋势:=3*Q3-2*Q4,COLORRED,LINETHICK3;

趋势线:=EMA(Q3, 3),COLORWHITE,LINETHICK3;

升1:=CROSS(MA(C,5),MA(C,33)) AND MID>REF(MID,1) AND ZA5>0 AND (长趋势>=趋势线 OR 长趋势>=REF(长趋势,1)),NODRAW,COLORRED;

升:=(NOT(跌) OR 涨 OR 升1) AND (ZA5>0.05 ) AND NOTEXT上笔划线 AND 斜率>=0,COLORMAGENTA;

DRAWTEXT(升 AND COUNT(升,5)=1,(B4+0.08),'升'),COLORYELLOW;

DRAWTEXT(跌 AND COUNT(跌 ,3)=1 AND ZA5<-0.05 AND 斜率<=-0.1,(B4 + 0.04),'跌'),COLORWHITE;

VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;

VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;

VAR400:=EMA(VAR300,5);

操盘:=3*VAR300-2*VAR400;

AW:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;

MAR3:=MA(C,3);

角度:=ATAN((MAR3/REF(MAR3,1)-1)*100)*180/3.14159>45 ,NODRAW;

RSV2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

K2:=SMA(RSV2,3,1);

D2:=SMA(K2,3,1);

KD金:=K2<30 AND D2<30 ;

LC:=REF(CLOSE,1);

RSI20:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;

底部:=CROSS(RSI20,11)*1,COLORRED;

MD:=(3*CLOSE+LOW+OPEN+HIGH)/6;

牛线:=(20*MD+19*REF(MD,1)+18*REF(MD,2)+17*REF(MD,3)+16*REF(MD,4)

+15*REF(MD,5)+14*REF(MD,6)+13*REF(MD,7)+12*REF(MD,8)+11*REF(MD,9)

+10*REF(MD,10)+9*REF(MD,11)+8*REF(MD,12)+7*REF(MD,13)+6*REF(MD,14)

+5*REF(MD,15)+4*REF(MD,16)+3*REF(MD,17)

+2*REF(MD,18)+REF(MD,20))/210 ,LINETHICK3,COLORYELLOW;

AAR:=MA(牛线,6);

ZBJ:=CROSS("MACD.DIF","MACD.DEA") ;

潜伏:=角度 AND CROSS(MAR3,AAR) AND KD金 OR ( ZBJ

AND REF(CROSS(K2,D2),1) AND MAR3>AAR) OR (CROSS(MAR3,AAR) AND CROSS(K2,D2));

STICKLINE(潜伏>0,L,H,3,0),COLORYELLOW;

STICKLINE(潜伏>0,L,H,1,0),COLORRED;

DRAWTEXT(潜伏>0 AND REF(TGLXS,1)>0 AND 斜率>=0 AND COUNT(潜伏>0,10)=1,H,'↙潜伏'),COLORYELLOW;

VOL5:=MA(VOL,5);

MA5:=MA(CLOSE,5);

MA4:=MA(CLOSE,4);

MA3:=MA(CLOSE,3);

抄底:=MA5>MA4 AND SLOPE(MA5,5)<0 AND SLOPE(MA4,4)<0 AND SLOPE(MA3,3) AND REF(MA4>MA3,1) AND CROSS(MA3,MA4) AND VOL>VOL5;

顶A:=CROSS(趋势线, 长趋势) AND MA3<=REF(MA3,1) AND 乖离<=0 AND REF(长趋势,1)>80;

AY:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;

BY:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));

DZ:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;

长期:=AY+100,COLOR9900FF;

短期:=BY+100,COLOR888888;

中期:=DZ+100,COLORYELLOW,LINETHICK2;

见顶:=(REF(中期,1)>85 AND REF(短期,1)>85 AND REF(长期,1)>65) AND CROSS(长期,短期);

顶部区:=(中期<REF(中期,1) AND REF(中期,1)>80) AND (REF(短期,1)>95 OR REF(短期,2)>95 ) AND 长期>60 AND 短期<83.5

AND 短期<中期 AND 短期<长期+4;

顶部:=FILTER(顶部区,4);

底部区:=(长期<12 AND 中期<8 AND (短期<7.2 OR REF(短期,1)<5) AND (中期>REF(中期,1) OR 短期>REF(短期,1)))

OR (长期<8 AND 中期<7 AND 短期<15 AND 短期>REF(短期,1)) OR (长期<10 AND 中期<7 AND 短期<1);

B11:=C<REF(C,4);

NT0:=BARSLASTCOUNT(B11);

A11:=C>REF(C,4);

NT:=BARSLASTCOUNT(A11);

TJ21:=NT0=9 ;

TJ12:=NT=9;

TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);

DRAWTEXT(NT=9,H*1.0002,'9'),COLORGREEN;

TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);

DRAWTEXT(NT0=9,L*0.9997,'9'),COLORRED;

VAR22:=LLV(LOW,10);

VAR23:=HHV(HIGH,25);

动力线:= EMA((CLOSE-VAR22)/(VAR23-VAR22)*4,4);

关注:=0.5,COLORYELLOW;

最小值:=LLV(LOW,25);

最大值:=HHV(HIGH,25);

波动线:=EMA((CLOSE-最小值)/(最大值-最小值)*100,4);

平均线:=EMA(波动线,3);

反转:=COUNT(MA(C,10)<REF(MA(C,10),1),3)>=2 AND CROSS(C,MA(C,20)) AND C>=MA(C,30) AND 平均线>=REF(平均线,1) AND 速率>0 AND 斜率>0;

DRAWTEXT(反转 AND COUNT(反转,6)=1 ,B4+0.42,'反转'),COLORWHITE;

STICKLINE(反转 AND COUNT(反转,6)=1,B4,B4+0.3,5,0),COLORCYAN;

VA1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

VA2:=SMA(ABS(LOW-VA1),13,1)/SMA(MAX(LOW-VA1,0),10,1);

VA3:=EMA(VA2,10)/100;

VA4:=LLV(LOW,33);

VA5:=EMA(IF(LOW<=VA4,VA3,0),3);

洗盘:=IF(VA5<REF(VA5,1),VA5,0),COLORGREEN,NODRAW;

拉升:=IF(VA5>REF(VA5,1) {AND 平均线>=REF(平均线,1)} ,VA5,0),COLORRED,NODRAW;

VA6:=IF(VA5>=100,100,VA5);

XP:=REF(洗盘,1);

LS:=拉升;

XPLS:=(XP AND LS);

DRAWTEXT(XPLS AND 斜率>-0.1 AND 速率>0 AND COUNT(XPLS,12)=1,B4-0.16,'洗尾'),COLORGREEN;

买1:=FILTER(CROSS(动力线,关注),20) AND 动力线<3 OR 潜伏 OR NT0 OR 反转 OR XPLS ;

V1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;

V2:=SMA(V1,3,1);

V3:=SMA(V2,3,1);

V4:=SMA(V3,3,1);

波:= V3;

段:= V4;

斜率D:=SLOPE(段,3)*10,COLORMAGENTA,NODRAW;

V5:=CROSS(V3,V4) AND V3<20;

低吸:= FILTER(V5,10)=1 AND 斜率>-0.1,COLORRED,NODRAW;

QZ:=250;

高点:=HHV(C,QZ);

低点:=LLV(C,QZ);

轴差:=高点-低点;

中价轴:=(高点+低点)/2;

HL3:=(100-0)/2*1.3;

HL4:=(100-0)/1*1.3;

中间价轴:=(50-HL3)*轴差/HL4+中价轴;

平安轴:=(中价轴+中间价轴)/2;

VQ7:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;

VVAR1:=(CLOSE+HIGH+LOW)/3;

VVAR2:=EMA(VVAR1,10);

VVAR3:=REF(VVAR2,1);

高抛:=CROSS(82,VQ7) AND C>平安轴 AND TGLXS<=10 AND VVAR2<VVAR3 AND 斜率>-0.05 ,NODRAW,COLORGREEN;

VAR301:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA

(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);

趋势:=EMA(VAR301,3)-10,COLORFF0000;

A13:=CROSS(趋势,0);

大底:= 底部 OR 低吸 OR 抄底;

RSI1:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100,COLORWHITE;

RSI2:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100,COLORWHITE;

鱼:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100,COLORRED;

RSI4:=SMA(鱼,7,1),LINETHICK1,COLORWHITE;

趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9,COLORFFFFFF;

趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9,COLOR3377DD;

AZ1:=MA(趋势A,7)*1.372,COLORGREEN,LINETHICK1;

AZ2:=AZ1*1.0887;

AZ3:=(1.5*(趋势B+RSI4)-(AZ2+AZ1))+12,COLORGREEN,LINETHICK1;

鱼网:=IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,AZ3) AND AZ3<38 AND RSI1<51),18,0),COLORYELLOW,LINETHICK2;

买入:=IF(EXIST(鱼网=18,8) AND 鱼>45 AND 鱼>REF( 鱼,2),1,0) AND 斜率>0,COLORMAGENTA,LINETHICK3;

买:=(A13 OR 买1 OR 涨 OR AW OR 抄底 OR 买入 OR AA1) AND COUNT((A13 OR 涨 OR 买1 OR AA1 OR AW OR 抄底 OR 买入),3)=1,COLORRED,NODRAW;

M1 := EMA( CLOSE, 9 );

M2 := EMA( CLOSE, 18 );

FA:=HHV(H,34);

FB:=LLV(L,34);

QS :((FA-FB)*动力线/100+FB +B4)/2, COLORWHITE, LINETHICK3;

MD2 :=M1 – M2, COLORWHITE, LINETHICK3;

MM :=EMA( QS, 3 );

MDD:=QS;

DRAWTEXT(买 AND NOTEXT上笔划线 , MDD-0.15,'买'),COLORRED;

VAR27:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);

VAR28:=CLOSE<MA(CLOSE,20) AND MA(CLOSE,20)<REF(MA(CLOSE,20),1);

逃:=EXIST ( 顶部 OR 高抛 OR VAR28 {OR 快卖} OR NT OR 顶 OR 顶A,6) AND 分界点 AND 顶;

DRAWTEXT((逃 OR 降 OR 跌 OR AA2) AND 超短线>0.3 AND ZA5<-0.15 AND COUNT(逃 OR 降 OR 跌 OR AA2 ,3)=1,B4+0.15,'逃'),COLORGREEN;

卖:=(逃 OR 降 OR 跌 OR AA2) AND B4< REF(B4,1) AND 超短线>0.3 AND COUNT(逃 OR 降 OR AA2 OR 跌,1)=1;

STICKLINE(卖 AND 超短线>0.3 AND 斜率<0 AND 速率<0 AND ZA5<-0.1 AND COUNT(卖,1)=1,B4,B4-0.10,4,0),COLORCYAN;

STICKLINE(降 AND COUNT(降,3)=1,B4,B4-0.10,2,0),COLORGREEN;

涨速:=ACCER*10000,NODRAW,COLORLIRED;

加速:=涨速-REF(涨速,1);

涨跌:=涨速+加速,NODRAW,COLORLIBLUE;

DRAWTEXT_FIX(1,0.46,0.12,0,STRCAT('涨速:',CON2STR(涨跌,2))),COLORYELLOW;

DRAWTEXT_FIX(1,0.46,0.26,0,STRCAT('乖离:',CON2STR(乖离,0))),COLORYELLOW;

预测:=MA(REF(HIGH,1)/REF(CLOSE,2),13)*REF(CLOSE,1)+涨跌,NODRAW;

最高:=CONST(高点),NODRAW;

最低:=CONST(低点),NODRAW;

DRAWTEXT_FIX(1,0.12,0.02,0,'前高:'),COLORMAGENTA;

DRAWNUMBER_FIX(1,0.24,0.02,0,CONST(最高)),COLORMAGENTA;

DRAWTEXT_FIX(1,0.12,0.07,0,'前低:'),COLORGREEN;

DRAWNUMBER_FIX(1,0.24,0.07,0,CONST(最低)),COLORGREEN;

MA60:=MA(CLOSE,60),COLORYELLOW, LINETHICK3;

BBI:=BBIBOLL,COLORYELLOW,LINETHICK3;

斜率B:=SLOPE(BBI,3)*10,COLORMAGENTA,NODRAW;

DIR2:=ABS(CLOSE-REF(CLOSE,30));

VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),30);

ER2:=DIR2/VIR2;

CS2:=ER2*(0.8-2/24)+2/24;

CQ2:=CS2*CS2;

M熊:=EMA(DMA(CLOSE,CQ2),2),COLORLIBLUE,LINETHICK6;

CK:=(BBI<REF(BBI,2) OR BBI<=REF(BBI,1))AND (BBI<=MA60 OR C<=BBI) AND VVAR2<VVAR3 ,NODRAW,COLORGREEN;

CHD:=BBI>MA60 OR VVAR2>=VVAR3 AND 斜率>0 {AND YY-金牛2>=0} AND BBI>=M熊,COLORRED,NODRAW;

CHK:=CK AND BBI<M熊 AND ABS( MA60-BBI)>=0.2 AND NOT(CHD),NODRAW,COLORWHITE;

牛熊:=M熊;

M震:=IF(M熊/REF(M熊,1)>0.997,M熊,DRAWNULL),COLORYELLOW,LINETHICK2;

M牛:=IF(M熊/REF(M熊,1)>1.001 {AND (重心>=平衡)},M熊,DRAWNULL),COLORRED,LINETHICK3;

DRAWTEXT_FIX(1,0.750,0.04,0,STRCAT('斜率:',CON2STR(斜率,2))),COLORLIRED;

XX1:=C>牛熊 AND 牛熊>REF(牛熊,1);

DRAWTEXT_FIX(ISLASTBAR AND XX1 AND 1,0.45,0.03,0,'【处于牛区】'),COLORRED;

XX2:=C<牛熊 AND 牛熊<=REF(牛熊,1);<br data-filtered=\\"filtered\\" sty

为您推荐

发表评论

邮箱地址不会被公开。 必填项已用*标注