优化经典CCI之选股指标公式

TYP:=(HIGH+LOW+CLOSE)/3;

游侠CCI:=EMA((TYP-MA(TYP,36.0270012))/(0.015*AVEDEV(TYP,36.0270012)),2.0332),COLORWHITE;

MA5:=MA(C,5);

MA10:=MA(C,10);

MA20:=MA(C,20);

MA60:=MA(C,60);

MA120:=MA(C,120);

角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;

角度MA10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;

角度MA60:=ATAN((MA60/REF(MA60,1)-1)*100)*180/3.1416;

角度MA120:=ATAN((MA120/REF(MA120,1)-1)*100)*180/3.1416;

DRAWICON(MA20>MA60 AND MA60>MA120 AND 角度MA60>0 AND 角度MA120>0 AND (C-L)/C*100 >=5 AND CROSS(游侠CCI,0),LOW,13);

为您推荐

发表评论

电子邮件地址不会被公开。 必填项已用*标注